fsiFoam 编译报错,算例无法运行

请问有人用过fsiFoam吗?我按照OpenWiki上的教程在Foam-extend 4.0基础上编译fsiFoam出现报错,算例无法运行,IMG_20200821_113545


有人知道是怎么回事吗?

你的系统是什么呢?下载的 fsiFoam 的版本是不是 4.0 呢?

系统是优麒麟18.04,fsiFoam版本是4.0的

在 CentOS 上用过,可以编译成功,也能用。

foam-extend 的路径有没有加入到 PATH 里面?看看 echo $PATH 输出什么?

换了Ubuntu16.04,编译成功啦,但fsiFoam里的第二个算例还是有报错,还在试图搞明白

系统编译环境不同造成的。第二个算例报错,是什么情况?可以贴出来么?

已经没问题啦 :smiley: :smiley: